We're currently investigating issues affecting website access

Incident Report for Soundtrack

Resolved

Our investigation indicated that the problem was due to our URLs being listed on a major network-level blacklist used by some ISPs and firewall/security solutions. That listing has since been cleared, and we are no longer seeing signs of disruption. Additionally, we have not received any new customer reports, which is a positive sign.

That said, we are continuing to monitor the situation closely.

If you're still experiencing issues, we recommend checking the following just as before:

Review your firewall or network security settings to ensure our services aren’t being blocked:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

Contact your ISP or network administrator to confirm that none of the following domains (or their subdomains) are being filtered:
- soundtrack.io
- soundtrackyourbrand.com

If problems persist, please contact us using this guide:
👉 https://help.soundtrack.io/hc/en-us/articles/19597790229788-Issues-affecting-website-access

As a temporary workaround, you may also try connecting from a different network with fewer restrictions.

We appreciate your patience and encourage you to reach out if you're still seeing issues—your feedback is invaluable in helping us ensure full service availability.
Posted Apr 24, 2025 - 12:04 UTC

Update

We’ve continued investigating the recent connectivity issues and have identified that the primary cause appears to be our URLs being listed on certain network-level blacklists. These blacklists are used by various ISPs and firewall/security solutions, which may be blocking access to our services.

We have successfully removed ourselves from one major blacklist, which we believe may have been the root cause of the incident. We are currently monitoring the results. However, if you are still experiencing issues, we recommend taking the following steps:

1. Check your firewall or network security settings to ensure our services are not being blocked:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

2. Contact your ISP or network administrator to confirm that none of the following primary domains—or their subdomains—are being filtered or blacklisted:
-soundtrack.io
-soundtrackyourbrand.com

3. If the issue persists after these checks, please reach out to our support team by following the steps outlined here:
👉 https://help.soundtrack.io/hc/en-us/articles/19597790229788-Issues-affecting-website-access

As a temporary workaround, you may also try connecting from a different network with less restrictive firewall settings.

We appreciate your patience and feedback, and will continue to monitor to resolve the situation.
Posted Apr 22, 2025 - 08:56 UTC

Update

We've continued investigating the recent connectivity issues and have identified that the primary cause appears to be related to our URLs being included on certain network-level blacklists. These blacklists are used by various ISPs and firewall/security solutions, which may be blocking access to our services.

We recommend taking the following steps if you're still experiencing problems:

Check your firewall or network security settings to ensure our services have access to network accordingly:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

Reach out to your ISP or network administrator to confirm that none of our following primary domains or their subdomains are being filtered or blacklisted:
- soundtrack.io
- soundtrackyourbrand.com

If the issue persists after completing these checks, please reach out to our support team by following the steps outlined here:
https://help.soundtrack.io/hc/en-us/articles/19597790229788-Issues-affecting-website-access

As a temporary solution, you can try connecting through a different network with less restrictive firewall settings to access our services.
Posted Apr 16, 2025 - 12:39 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2025 - 12:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2025 - 12:37 UTC

Update

We've continued investigating the recent connectivity issues and have identified that the primary cause appears to be related to our URLs being included on certain network-level blacklists. These blacklists are used by various ISPs and firewall/security solutions, which may be blocking access to our services.

We recommend taking the following steps if you're still experiencing problems:

Check your firewall or network security settings to ensure our URLs are not being blocked.

Reach out to your ISP or network administrator to confirm that none of our domains are being filtered or blacklisted.

You can find our general firewall guidance here:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

If issues persist after these checks, please contact our support team at support@soundtrackyourbrand.com, and we’ll assist you further.

As a temporary solution, you can try connecting through a different network with less restrictive firewall settings to access our services.

Thank you again for your patience and understanding as we work to resolve this.
Posted Apr 15, 2025 - 12:02 UTC

Monitoring

We've continued investigating the recent connectivity issues and have identified that the primary cause appears to be related to our URLs being included on certain network-level blacklists. These blacklists are used by various ISPs and firewall/security solutions, which may be blocking access to our services.

We recommend taking the following steps if you're still experiencing problems:

Check your firewall or network security settings to ensure our URLs are not being blocked.

Reach out to your ISP or network administrator to confirm that none of our domains are being filtered or blacklisted.

You can find our general firewall guidance here:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

If issues persist after these checks, please contact our support team at support@soundtrackyourbrand.com, and we’ll assist you further.

Thank you again for your patience and understanding as we work to resolve this.
Posted Apr 15, 2025 - 07:23 UTC

Identified

We've been working closely with many customers and have found that in several cases, the issue is related to network-level filtering, such as local firewall settings or ISP-imposed restrictions.

We recommend reviewing your network configuration to ensure that access to our services isn't being blocked, and contacting your ISP if needed.

You can find general firewall guidance here:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

If you're still experiencing issues, please contact us at support@soundtrackyourbrand.com

We appreciate your continued patience and will share more updates as they become available.
Posted Apr 12, 2025 - 09:12 UTC

Update

We've been working closely with many customers and have found that in several cases, the issue is related to network-level filtering, such as local firewall settings or ISP-imposed restrictions.

We recommend reviewing your network configuration to ensure that access to our services isn't being blocked, and contacting your ISP if needed.

You can find general firewall guidance here:
👉 https://help.soundtrack.io/hc/en-us/articles/115002592192-Firewall-settings

If you're still experiencing issues, please contact us at support@soundtrackyourbrand.com

We appreciate your continued patience and will share more updates as they become available.
Posted Apr 12, 2025 - 08:50 UTC

Monitoring

Some users are reporting problems visiting our websites, including error messages like "Something went wrong" or "Your connection is not private".

Our team is actively investigating and working to resolve the issue as quickly as possible.

In the meantime, you can try the following workarounds:
- Use a different browser
- Clear your browser cache
- Log out and log back in

If you're still experiencing issues, please contact us at support@soundtrackyourbrand.com

Thank you for your patience!
Posted Apr 10, 2025 - 12:23 UTC
This incident affected: Account Management.