We are currently experiencing a problem with our service

Incident Report for Soundtrack

Resolved

The issue has been resolved, and operations are now running smoothly. Everything is back to normal, so kick back, relax, and enjoy some fresh new tunes!
Posted Oct 30, 2024 - 12:27 UTC

Update

Some users are currently experiencing issues on browsing for new and existing music. We are currently working on this and will provide an update as soon as possible.
Posted Oct 30, 2024 - 11:23 UTC

Investigating

We are currently investigating this issue.
Posted Oct 30, 2024 - 11:18 UTC
This incident affected: Music Management.