Increased track download levels

Incident Report for Soundtrack

Resolved

This incident has been resolved.
Posted Oct 19, 2023 - 11:25 UTC

Update

We are continuing to investigate this issue.
Posted Oct 19, 2023 - 11:12 UTC

Investigating

We are currently investigating this issue.
Posted Oct 19, 2023 - 11:07 UTC