We are currently experiencing a problem with our service

Incident Report for Soundtrack

Resolved

We regret to inform you that our platform is currently experiencing a partial outage that is affecting some services. Users may encounter difficulties accessing any part of our platform, including website, app, and customer support channels.
Posted Apr 23, 2025 - 14:07 UTC

Identified

We regret to inform you that our platform is currently experiencing a partial outage that is affecting some services. Users may encounter difficulties accessing any part of our platform, including website, app, and customer support channels.
Posted Apr 23, 2025 - 14:05 UTC

Investigating

We regret to inform you that our platform is currently experiencing a partial outage that is affecting some services. Users may encounter difficulties accessing any part of our platform, including website, app, and customer support channels.
Posted Apr 23, 2025 - 13:59 UTC