Limited functionality on website and app

Incident Report for Soundtrack

Resolved

The incident is now resolved.
Posted Mar 08, 2024 - 10:59 UTC

Identified

We are currently investigating this issue.
Posted Mar 08, 2024 - 10:45 UTC

Update

We are continuing to investigate this issue.
Posted Mar 07, 2024 - 20:49 UTC

Investigating

We are currently investigating this issue.
Posted Mar 07, 2024 - 20:46 UTC